summary refs log tree commit diff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:27 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:32:14 -0500
commit992d69b1e76dfc5b342176bb15437ac2f3690ea9 (patch)
tree4b96db35b1943cb28cbfd04613f6aab2ad1bacc7
parent088af734098fdf30d5fcc6be614e30a8cb04751b (diff)
downloadguix-992d69b1e76dfc5b342176bb15437ac2f3690ea9.tar.gz
gnu: Add go-github-com-emersion-go-msgauth.
* gnu/packages/golang.scm (go-github-com-emersion-go-msgauth): New
  variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index eea2d2e10d..e7a6b00bd9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6791,6 +6791,36 @@ format.")
 filters for Go.")
     (license license:bsd-2)))
 
+(define-public go-github-com-emersion-go-msgauth
+  (package
+    (name "go-github-com-emersion-go-msgauth")
+    (version "0.6.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emersion/go-msgauth")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ds8yr4cm9wigcxg1sxc2m0wmy4z9n6gws3mj50dmf2ayij69z9j"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/emersion/go-msgauth"
+           #:tests? #f ; Source-only package.
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Source-only package.
+               (delete 'build))))
+    (propagated-inputs (list go-golang-org-x-crypto
+                             go-github-com-emersion-go-milter
+                             go-github-com-emersion-go-message))
+    (home-page "https://github.com/emersion/go-msgauth")
+    (synopsis "Email authentication for Go")
+    (description
+     "This package provides a Go library for authenticating emails.")
+    (license license:expat)))
+
 (define-public go-github-com-fatih-color
   (package
     (name "go-github-com-fatih-color")