summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:31:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:42 +0200
commit9ae2f42ad6da714d6183f46c74d951750f26f119 (patch)
tree0b381f8fb6939a5461b9d987ddc45e5899a7233f
parentc907fa75c742598436ffce83243000ccc77fbf2d (diff)
downloadguix-9ae2f42ad6da714d6183f46c74d951750f26f119.tar.gz
gnu: Add texlive-pst-platon.
* gnu/packages/tex.scm (texlive-pst-platon): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 658750a7cf..9953f35106 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33761,6 +33761,26 @@ files from spreadsheets is available.")
 with an arbitrarily chosen angle and a variable shortening factor.")
     (license license:lppl1.3+)))
 
+(define-public texlive-pst-platon
+  (package
+    (name "texlive-pst-platon")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-platon/"
+                   "source/generic/pst-platon/"
+                   "tex/latex/pst-platon/")
+             (base32
+              "0a4w47varc1i22h5iwd49c0clwb2k8hdlva5l6nfmc889wgwp0d7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-platon")
+    (synopsis "Platonic solids in PSTricks")
+    (description
+     "The package adds to PSTricks the ability to draw 3-dimensional views of
+the five Platonic solids.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")