summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-23 18:44:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-10 20:24:11 +0200
commitaddc808ddc4a97bb55b13a82e580664429175910 (patch)
tree95b9192205d58c7c3c8cef8ad8a19ba2010e6af9
parent358c3d612b00f58f713746b7ec6ca11c7b03875e (diff)
downloadguix-addc808ddc4a97bb55b13a82e580664429175910.tar.gz
gnu: Add python-wheel.
* gnu/packages/python.scm (python-wheel, python2-wheel): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 91c9328230..6a7fbf8524 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2164,6 +2164,33 @@ with sensible defaults out of the box.")
 (define-public python2-click
   (package-with-python2 python-click))
 
+(define-public python-wheel
+  (package
+    (name "python-wheel")
+    (version "0.26.0")
+      (source
+        (origin
+          (method url-fetch)
+          (uri (pypi-uri "wheel" version))
+          (sha256
+            (base32
+             "032k1ajijbqnv0z0k88bhf75mdimi18fcmm28mss90610lw3bbga"))))
+  (build-system python-build-system)
+  (native-inputs
+   `(("python-setuptools" ,python-setuptools)
+     ("python-jsonschema" ,python-jsonschema)
+     ("python-pytest-cov" ,python-pytest-cov)))
+  (home-page "https://bitbucket.org/pypa/wheel/")
+  (synopsis "Built-package format for Python")
+  (description
+   "A wheel is a ZIP-format archive with a specially formatted filename and the
+.whl extension.  It is designed to contain all the files for a PEP 376
+compatible install in a way that is very close to the on-disk format.")
+  (license license:expat)))
+
+(define-public python2-wheel
+  (package-with-python2 python-wheel))
+
 (define-public python-requests
   (package
     (name "python-requests")