summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-07 20:15:28 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-07 20:15:28 +0100
commitbdbf227fa3c1112ac19992711411c448bcf12735 (patch)
tree4eb221780f19ca42287365dd70278b629050a441
parent1cb9c00614da7a9d56e2ee28c6da1bd8a53ef4e1 (diff)
downloadguix-bdbf227fa3c1112ac19992711411c448bcf12735.tar.gz
gnu: xpdf: Fix detection of freetype.
* gnu/packages/pdf.scm (xpdf)[configure-flags]: Add flag to correctly detect
  freetype. Otherwise, the xpdf binary is not built.
-rw-r--r--gnu/packages/pdf.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index f75a060a4b..21fb39562b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -127,7 +127,11 @@
              ("zlib" ,zlib)))
    (arguments
     `(#:tests? #f ; there is no check target
-      #:parallel-build? #f            ; build fails randomly on 8-way machines
+      #:parallel-build? #f ; build fails randomly on 8-way machines
+      #:configure-flags
+        (list (string-append "--with-freetype2-includes="
+                             (assoc-ref %build-inputs "freetype")
+                             "/include/freetype2"))
       #:phases
        (alist-replace
         'install