summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:26:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:19 +0200
commitc0fb7de8de7248e814ab6f1be6bfc13d49a155d5 (patch)
tree5d21de170abad85dd587fb491d29be6698ef9f09
parent8c442d08bf3332806741e69a72341bd90f04b4d9 (diff)
downloadguix-c0fb7de8de7248e814ab6f1be6bfc13d49a155d5.tar.gz
gnu: Add texlive-tex-nutshell.
* gnu/packages/tex.scm (texlive-tex-nutshell): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc0c68b365..bf5927ca06 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25452,6 +25452,26 @@ integrating fonts, and explains how some of the most common font-related error
 messages occur.  Also, hints are given on how to address those.")
     (license license:lppl)))
 
+(define-public texlive-tex-nutshell
+  (package
+    (name "texlive-tex-nutshell")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/tex-nutshell/")
+             (base32
+              "1pc9hx4fzk0k6lwab6galf7gxm55x4z250dymsmbz4fan76xk51x")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tex-nutshell")
+    (synopsis "Short document about TeX principles")
+    (description
+     "This document is meant for users who are looking for information about
+the basics of TeX.  Its main goal is its brevity.  The pure TeX features are
+described, no features provided by macro extensions.  Only the last section
+gives a summary of plain TeX macros.")
+    (license license:public-domain)))
+
 (define-public texlive-threeparttable
   (package
     (name "texlive-threeparttable")