summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:20 +0200
commitc60b6c817fe8cdb1a8cc965ee8ddaa26887b6a7d (patch)
treeeba5f25a0c850e781db9e1f7ecc37270ce28737f
parent02db014892a576f1a3f3ab6eda2fce9a1226472d (diff)
downloadguix-c60b6c817fe8cdb1a8cc965ee8ddaa26887b6a7d.tar.gz
gnu: Add texlive-sphack.
* gnu/packages/tex.scm (texlive-sphack): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7100d28fd5..5e6e20e78e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96201,6 +96201,25 @@ package requires pdfLaTeX; sparklines cannot appear in a DVI file.  The
 sparklines package uses PGF.")
     (license license:lppl)))
 
+(define-public texlive-sphack
+  (package
+    (name "texlive-sphack")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sphack/" "tex/latex/sphack/")
+             (base32
+              "1pami588h0lw8f79idy088bwhfjrf2q993nrjw8cb0bpsbqqmrx6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sphack")
+    (synopsis "Patch LaTeX kernel spacing macros")
+    (description
+     "This package changes the kernel internal
+@code{\\@@bsphack}/@code{\\@@esphack} so that it is also invisible in vertical
+mode.")
+    (license license:knuth)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar