summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 13:57:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:31 +0200
commitcf937f92313b141c8d6e8c0646e9f0928744bc93 (patch)
treebf4859ef5fa4ca6a145c15031385150a60572eb9
parentf95f4d7a87ee45d268b24b1ca94eab03ecac3eb6 (diff)
downloadguix-cf937f92313b141c8d6e8c0646e9f0928744bc93.tar.gz
gnu: texlive-pagenote: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-pagenote!): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e550ef5fc4..e7d9af1b34 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11975,27 +11975,25 @@ whether an argument is empty.")
     (license license:lppl1.3c+)))
 
 (define-public texlive-pagenote
-  (let ((template (simple-texlive-package
-                   "texlive-pagenote"
-                   (list "/doc/latex/pagenote/"
-                         "/source/latex/pagenote/")
-                   (base32
-                    "0cqfqrfvnzq7ldaf255hcvi8xsfx8h7iha3hs8p9gdi3cfzbcmjm"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/pagenote")
-         ((#:build-targets _ '())
-          ''("pagenote.ins"))))
-      (propagated-inputs
-       (list texlive-ifmtarg))
-      (home-page "https://www.ctan.org/pkg/pagenote")
-      (synopsis "Notes at end of document")
-      (description "The pagenote package provides tagged notes on a separate
-page (also known as ‘end notes’).")
-      (license license:lppl1.3c+))))
+  (package
+    (name "texlive-pagenote")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pagenote/" "source/latex/pagenote/"
+                   "tex/latex/pagenote/")
+             (base32
+              "1dffh7ac13w3gs94lvfxgw1i4k6cfkrpcyikj1sfrqaivrxpmqpi")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-ifmtarg))
+    (home-page "https://ctan.org/pkg/pagenote")
+    (synopsis "Notes at end of document")
+    (description
+     "The @code{pagenote} package provides tagged notes on a separate
+page (also known as end notes).")
+    (license license:lppl1.3c+)))
 
 (define-public texlive-titling
   (let ((template (simple-texlive-package