summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-06-17 08:11:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-17 21:18:19 +0200
commitd1dbeddd5553bb2f67a6bbbe5282baa9967ffbe5 (patch)
treec851d45dc728c3e35f7c75312fc44754bd514232
parent65924b10bc4bcd71ea5c5f3f0d889b3e93eb523c (diff)
downloadguix-d1dbeddd5553bb2f67a6bbbe5282baa9967ffbe5.tar.gz
gnu: Add emacs-company.
* gnu/packages/emacs.scm (emacs-company): New variable.
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cb6464df9d..bbb4baa30f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1333,6 +1333,29 @@ view the build status of those servers' build jobs, and possibly to trigger
 build jobs.")
     (license license:gpl3+)))
 
+(define-public emacs-company
+  (package
+    (name "emacs-company")
+    (version "0.8.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/company-mode/company-mode/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1vwmbqm7h4lrszv2qxy6fqzznm9raigi84cadx982c9m7shp0zzz"))))
+    (build-system emacs-build-system)
+    (home-page "http://company-mode.github.io/")
+    (synopsis "Modular text completion framework")
+    (description
+     "Company is a modular completion mechanism.  Modules for retrieving
+completion candidates are called back-ends, modules for displaying them are
+front-ends.  Company comes with many back-ends, e.g. @code{company-elisp}.
+These are distributed in separate files and can be used individually.")
+    (license license:gpl3+)))
+
 (define-public typo
   (package
     (name "emacs-typo")