summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:24:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:14 +0200
commitd95fa8ead01f130186028837c502fbc906255f53 (patch)
treeec7ef78a6381f1a18891e9b52a1e42b0c8c94b1d
parentd3ab4f7a7db85b6d45c8b10472f64e2517963a6e (diff)
downloadguix-d95fa8ead01f130186028837c502fbc906255f53.tar.gz
gnu: Add texlive-hep-font.
* gnu/packages/tex.scm (texlive-hep-font): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fc7c1a039c..7c2fc8d44a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14090,6 +14090,27 @@ makes full use of all BibTeX fields provided by Discover High-Energy
 Physics.")
     (license license:lppl1.3c)))
 
+(define-public texlive-hep-font
+  (package
+    (name "texlive-hep-font")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/hep-font/"
+                   "source/fonts/hep-font/"
+                   "tex/latex/hep-font/")
+             (base32
+              "0wf39qf896abj0ypgz0655pm055ywch3jlpnxd8pgaip6igbs5g9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hep-font")
+    (synopsis "Latin modern extended by Computer Modern")
+    (description
+     "The @code{hep-font} package loads standard font packages and extends the
+usual Latin Modern implementations by replacing missing fonts with Computer
+Modern counterparts.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-hep-reference
   (package
     (name "texlive-hep-reference")