summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 00:32:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:39 +0200
commite1e0e08451e84ccb7530e5a8187367333f1f87ee (patch)
tree4374feefb421d2a8b222cc4efcc2441c4a058429
parent36e77dbd2a30edc8096b22dd692d3d62424ea50a (diff)
downloadguix-e1e0e08451e84ccb7530e5a8187367333f1f87ee.tar.gz
gnu: texlive-latex-newunicodechar -> texlive-newunicodechar.
* gnu/packages/tex.scm (texlive-newunicodechar): New variable.
(texlive-latex-newunicodechar): Deprecate variable.
* gnu/packages/maths.scm (hypre): Use new name.
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm20
2 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 052e9c791d..fe4d23c2e8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5809,7 +5809,7 @@ set.")
                                      texlive-latex-multirow
                                      texlive-natbib
                                      texlive-latex-needspace
-                                     texlive-latex-newunicodechar
+                                     texlive-newunicodechar
                                      texlive-latex-parskip
                                      texlive-latex-stackengine
                                      texlive-latex-tabulary
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 71696fe6e5..4c78950cca 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5401,14 +5401,18 @@ the LaTeX standard foating environments @code{figure} and @code{table}.")
 
 (define-deprecated-package texlive-latex-newfloat texlive-newfloat)
 
-(define-public texlive-latex-newunicodechar
+(define-public texlive-newunicodechar
   (package
-    (inherit (simple-texlive-package
-              "texlive-latex-newunicodechar"
-              '("/doc/latex/newunicodechar/" "/tex/latex/newunicodechar/")
-              (base32
-               "0pwx3ylhvk5hxjnalas00grrbwla79j424i27hrm0zgflq7wsbrj")
-              #:trivial? #t))
+    (name "texlive-newunicodechar")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/newunicodechar/" "source/latex/newunicodechar"
+                   "tex/latex/newunicodechar/")
+             (base32
+              "0mybqah1n9vmxvi6f587jlxbn7pv3624qw83psq5vwfnddw3n70y")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
     (home-page "https://www.ctan.org/pkg/newunicodechar")
     (synopsis "Definitions of the meaning of Unicode characters")
     (description
@@ -5417,6 +5421,8 @@ Unicode characters.  The document should be processed by (pdf)LaTeX with the
 Unicode option of @code{inputenc} or @code{inputenx}, or by XeLaTeX/LuaLaTeX.")
     (license license:lppl1.3c+)))
 
+(define-deprecated-package texlive-latex-newunicodechar texlive-newunicodechar)
+
 (define-public texlive-pdftexcmds
   (let ((template (simple-texlive-package
                    "texlive-pdftexcmds"