summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:25:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:14 +0200
commite49d92af550eb2b6149d83faf21d7749dbd8df1e (patch)
tree4afd071c325974b359eb01a9807892c195b88cdb
parentd95fa8ead01f130186028837c502fbc906255f53 (diff)
downloadguix-e49d92af550eb2b6149d83faf21d7749dbd8df1e.tar.gz
gnu: Add texlive-hep-math-font.
* gnu/packages/tex.scm (texlive-hep-math-font): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7c2fc8d44a..66cebf69d4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14111,6 +14111,28 @@ usual Latin Modern implementations by replacing missing fonts with Computer
 Modern counterparts.")
     (license license:lppl1.3c)))
 
+(define-public texlive-hep-math-font
+  (package
+    (name "texlive-hep-math-font")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/hep-math-font/"
+                   "source/fonts/hep-math-font/"
+                   "tex/latex/hep-math-font/")
+             (base32
+              "07lb2sxzdff9arpfksz186dvpgr6slfz637xinhf95npbylpyww3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hep-math-font")
+    (synopsis "Extended Greek and sans-serif math")
+    (description
+     "The @code{hep-math-font} package adjust the math fonts to be sans-serif
+if the document is sans-serif.  Additionally Greek letters are redefined to be
+always italic and upright in math and text mode respectively.  Some math font
+macros are adjusted to give more consistently the naively expected results.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-hep-reference
   (package
     (name "texlive-hep-reference")