summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:27:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:17 +0200
commiteb1d71a427b3c5cd59bba9f8877f7ee9c2b95d82 (patch)
treec20d3592ac3ce10d23229e87aa752f67cda97cb5
parent48969d3158c9f1ede8b399c8a5b7edbc9e3ab921 (diff)
downloadguix-eb1d71a427b3c5cd59bba9f8877f7ee9c2b95d82.tar.gz
gnu: Add texlive-inter.
* gnu/packages/tex.scm (texlive-inter): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9a7ea00350..5083bda59d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14955,6 +14955,35 @@ footnotes.")
 Live and mainly introducing command line operations, in Chinese.")
     (license license:lppl1.3c)))
 
+(define-public texlive-inter
+  (package
+    (name "texlive-inter")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/inter/"
+                   "fonts/enc/dvips/inter/"
+                   "fonts/map/dvips/inter/"
+                   "fonts/opentype/public/inter/"
+                   "fonts/tfm/public/inter/"
+                   "fonts/type1/public/inter/"
+                   "fonts/vf/public/inter/"
+                   "tex/latex/inter/")
+             (base32
+              "1rvh2f066lkdbr8754r0a016k9imcjpia9wdi46x70d96wgcb5vm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/inter")
+    (synopsis "Inter font face with support for LaTeX, XeLaTeX, and LuaLaTeX")
+    (description
+     "This package provides LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX support for
+the Inter Sans family of fonts, designed by Rasmus Andersson.  Inter is
+a typeface specially designed for user interfaces with focus on high
+legibility of small-to-medium sized text on computer screens.  The family
+features a tall x-height to aid in readability of mixed-case and lower-case
+text.")
+    (license (list license:silofl1.1 license:lppl))))
+
 (define-public texlive-interval
   (package
     (name "texlive-interval")