summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:59 +0200
commitfc5192814239f62870ae6bd58df0d0d0e9880eac (patch)
tree93b6fc6322156b5114e5f031db2249804b8244af
parent659bb9a7b32ad131d2336cb040f356ee7aba6c1d (diff)
downloadguix-fc5192814239f62870ae6bd58df0d0d0e9880eac.tar.gz
gnu: Add texlive-semantic.
* gnu/packages/tex.scm (texlive-semantic): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9e48ee4ae7..84cdbaabdc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95012,6 +95012,26 @@ called @code{stripsemantex}, which allows you to completely strip your
 documents of SemanTeX markup to prepare them e.g., for publication.")
     (license license:lppl1.3c)))
 
+(define-public texlive-semantic
+  (package
+    (name "texlive-semantic")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/semantic/"
+                   "source/latex/semantic/"
+                   "tex/latex/semantic/")
+             (base32
+              "14v1538y7gsn63833j41z9yan8cpn2c4pls2rwyyk7qmzjj30nh7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/semantic")
+    (synopsis "Help for writing programming language semantics")
+    (description
+     "This package eases the typesetting of notation of semantics and compilers.
+It includes T-diagrams, various derivation symbols and inference trees.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar