summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 18:57:56 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commit429bbef8496cb2e21509f162de21496e446f78fc (patch)
treecc4c87db161de94d18795181216db046c66711dd /gnu/packages/check.scm
parent14a9996cc24dfedb6467896e0e43220322c148ff (diff)
downloadguix-429bbef8496cb2e21509f162de21496e446f78fc.tar.gz
gnu: python-pytest-xdist: Add extra test input, don't propagate pytest.
* gnu/packages/check.scm (python-pytest-xdist)[native-inputs]: Add
PYTHON-FILELOCK.  While at it, add PYTHON-PYTEST from ...
[propagated-inputs]: ... here.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8a83c88a04..6653326c18 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1331,9 +1331,8 @@ same arguments.")
              (when tests?
                (invoke "pytest" "-vv"
                        "-n" (number->string (parallel-job-count)))))))))
-    (native-inputs (list python-setuptools-scm))
-    (propagated-inputs (list python-execnet python-pytest python-py
-                             python-pytest-forked))
+    (native-inputs (list python-setuptools-scm python-filelock python-pytest))
+    (propagated-inputs (list python-execnet python-pytest-forked))
     (home-page "https://github.com/pytest-dev/pytest-xdist")
     (synopsis
      "Plugin for py.test with distributed testing and loop-on-failing modes")