summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2024-04-19 16:22:26 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-04-19 21:18:40 +0800
commitee64afca1f1c62a5dd1cde6cde6fde8d041fa693 (patch)
tree5834eeaddacb2fef3c8e039a9307a78703e903d2 /gnu/packages/fonts.scm
parentcb31ea20ca13a0e9cde521360fe0020260900bd4 (diff)
downloadguix-ee64afca1f1c62a5dd1cde6cde6fde8d041fa693.tar.gz
gnu: Add font-plangothic.
* gnu/packages/fonts.scm (font-plangothic): New variable.

Change-Id: I5982af96057dbb7c354ebfa32c173b25cf883461
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index f540c3bc9a..042368ef47 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2983,6 +2983,37 @@ It is generated by the font shape data in GlyphWiki using KAGE system, Clipper
 and FontForge.")
     (license license:cc0)))
 
+(define-public font-plangothic
+  (package
+    (name "font-plangothic")
+    (version "1.8.5760")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/"
+             "Plangothic-Project/releases/download/V"
+             version "/Plangothic.ttc"))
+       (sha256
+        (base32 "0ha2hcgy95ibmjk8lqfz0ihfc09swrzz3grlchma7qrwyxqbwpc0"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(let* ((out #$output)
+               (dest (string-append out "/share/fonts/truetype")))
+          (use-modules (guix build utils))
+          (mkdir-p dest)
+          (copy-file #$(package-source this-package)
+                     (string-append dest "/Plangothic.ttc")))))
+    (home-page
+     "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project")
+    (synopsis "Sans font covers most CJK unified ideograph characters")
+    (description "Plangothic is a sans font based on Source Han Sans,
+modified to cover most CJK unified ideograph characters.")
+    (license license:silofl1.1)))
+
 (define-public font-fontna-yasashisa-antique
   (package
     (name "font-fontna-yasashisa-antique")