summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index f540c3bc9a..042368ef47 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2983,6 +2983,37 @@ It is generated by the font shape data in GlyphWiki using KAGE system, Clipper
 and FontForge.")
     (license license:cc0)))
 
+(define-public font-plangothic
+  (package
+    (name "font-plangothic")
+    (version "1.8.5760")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/"
+             "Plangothic-Project/releases/download/V"
+             version "/Plangothic.ttc"))
+       (sha256
+        (base32 "0ha2hcgy95ibmjk8lqfz0ihfc09swrzz3grlchma7qrwyxqbwpc0"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(let* ((out #$output)
+               (dest (string-append out "/share/fonts/truetype")))
+          (use-modules (guix build utils))
+          (mkdir-p dest)
+          (copy-file #$(package-source this-package)
+                     (string-append dest "/Plangothic.ttc")))))
+    (home-page
+     "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project")
+    (synopsis "Sans font covers most CJK unified ideograph characters")
+    (description "Plangothic is a sans font based on Source Han Sans,
+modified to cover most CJK unified ideograph characters.")
+    (license license:silofl1.1)))
+
 (define-public font-fontna-yasashisa-antique
   (package
     (name "font-fontna-yasashisa-antique")