summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 10:37:19 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 10:37:19 +0200
commita62df7cd72423e9ea7cf030a4db034c548eeb59e (patch)
treec49874be3b2af7004c6e3846f289cbf8fb36fae7 /gnu/packages/gdb.scm
parentef2a3871fdebb5aa2b34fefbeec8d7be92e6097e (diff)
downloadguix-a62df7cd72423e9ea7cf030a4db034c548eeb59e.tar.gz
gnu: GDB: Remove version 9.1.
* gnu/packages/gdb.scm (gdb-9.1): Rename to ...
(gdb): ... this.  Update to 9.2.
[source](patches): Add 'gdb-hurd.patch'.
(gdb-8.2): Inherit from GDB instead of GDB-9.1.
(gdb-9.2): Remove variable.
(gdb-minimal): Inherit from GDB instead of GDB-9.2.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm29
1 files changed, 6 insertions, 23 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 338b73aa58..2615f1f158 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -40,17 +40,18 @@
   #:use-module (guix build-system gnu)
   #:use-module (srfi srfi-1))
 
-(define-public gdb-9.1
+(define-public gdb
   (package
     (name "gdb")
-    (version "9.1")
+    (version "9.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gdb/gdb-"
                                  version ".tar.xz"))
+             (patches (search-patches "gdb-hurd.patch"))
              (sha256
               (base32
-               "0dqp1p7w836iwijg1zb4a784n0j4pyjiw5v6h8fg5lpx6b40x7k9"))))
+               "0mf5fn8v937qwnal4ykn3ji1y2sxk0fa1yfqi679hxmpg6pdf31n"))))
 
     (build-system gnu-build-system)
     (arguments
@@ -125,7 +126,7 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
 ;; <https://bugs.gnu.org/37810>.
 (define-public gdb-8.2
   (package
-    (inherit gdb-9.1)
+    (inherit gdb)
     (version "8.2.1")
     (source (origin
               (method url-fetch)
@@ -135,27 +136,9 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
                (base32
                 "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
 
-(define-public gdb
-  ;; This is the fixed version that packages depend on.  Update it rarely
-  ;; enough to avoid massive rebuilds.
-  gdb-9.1)
-
-(define-public gdb-9.2
-  (package
-    (inherit gdb)
-    (version "9.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnu/gdb/gdb-"
-                                  version ".tar.xz"))
-              (patches (search-patches "gdb-hurd.patch"))
-              (sha256
-               (base32
-                "0mf5fn8v937qwnal4ykn3ji1y2sxk0fa1yfqi679hxmpg6pdf31n"))))))
-
 (define-public gdb-minimal
   (package/inherit
-   gdb-9.2
+   gdb
    (name "gdb-minimal")
    (inputs (fold alist-delete (package-inputs gdb)
                  '("guile" "libxml2" "ncurses" "python-wrapper"