summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 10:02:01 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 10:02:01 +0200
commita81b8dfeb5a882e27e3df873e3e68ea16b1f9458 (patch)
treee9b39099a40b0968ec4559bf8a49fe4da15589f4 /gnu/packages/gdb.scm
parent361541d4a51b343694f9f14f150d3c6612490687 (diff)
downloadguix-a81b8dfeb5a882e27e3df873e3e68ea16b1f9458.tar.gz
gnu: gdb@8.2: Do not inherit replacements from 'gdb'.
* gnu/packages/gdb.scm (gdb-8.2): Use INHERIT instead of PACKAGE/INHERIT.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 5c8ea0c62b..d8865582be 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -130,16 +130,16 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
 ;; This version of GDB is required by some of the Rust compilers, see
 ;; <https://bugs.gnu.org/37810>.
 (define-public gdb-8.2
-  (package/inherit
-   gdb-9.1
-   (version "8.2.1")
-   (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/gdb/gdb-"
-                                 version ".tar.xz"))
-             (sha256
-              (base32
-               "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
+  (package
+    (inherit gdb-9.1)
+    (version "8.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gdb/gdb-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
 
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely