summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-20 03:20:01 -0500
committerLeo Famulari <leo@famulari.name>2017-12-20 16:41:41 -0500
commit0e06bec250f34dbab378b2c1e937af75db900bcc (patch)
tree9e513790efed4646986d3a196e083f8df5ee2152 /gnu/packages/gnupg.scm
parente6f63412c9abe6a3b4ddf0ce39735d1e2a65491d (diff)
downloadguix-0e06bec250f34dbab378b2c1e937af75db900bcc.tar.gz
gnu: gpgme: Build with the latest GnuPG.
* gnu/packages/gnupg.scm (gpgme)[inputs]: Use the latest gnupg package.
[arguments]: Keep a reference to the gnupg package used for build.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index a9b097b212..7a791aecd2 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -385,10 +385,14 @@ libskba (working with X.509 certificates and CMS data).")
      ;; Needs to be propagated because gpgme.h includes gpg-error.h.
      `(("libgpg-error" ,libgpg-error)))
     (inputs
-     `(("gnupg" ,gnupg-2.0)
+     `(("gnupg" ,gnupg)
        ("libassuan" ,libassuan)))
     (arguments
-     `(#:phases
+     `(#:configure-flags
+       (list (string-append "--enable-fixed-path="
+                            (assoc-ref %build-inputs "gnupg")
+                            "/bin"))
+       #:phases
        (modify-phases %standard-phases
          (add-after 'configure 'patch-cmake-file
            (lambda _