summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:48 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:15 -0500
commitfae3b9d5988393e5385c5d3d067b1412fd1044a2 (patch)
tree8e44e929286f61c82243001cf4300f0e6b59b1cf /gnu/packages/golang.scm
parente0060729b5dfa678bd686ad20435485a73f3d4d0 (diff)
downloadguix-fae3b9d5988393e5385c5d3d067b1412fd1044a2.tar.gz
gnu: go-github-com-gorilla-handlers: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-handlers): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

* gnu/packages/backup.scm: Add (gnu packages golang-web) module.

Change-Id: I7535bdecc681e230f4aee70115a3dea847d40e6f
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f51d8fd455..fb826c2743 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4867,32 +4867,6 @@ the @code{c2go} tool at
 @url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
     (license license:expat)))
 
-(define-public go-github-com-gorilla-handlers
-  (package
-    (name "go-github-com-gorilla-handlers")
-    (version "1.5.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/gorilla/handlers")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "15gycdz9lkjnsvvichsbdf25vf6pi1sfn41khhz53iqf300l0w0s"))))
-    (build-system go-build-system)
-    (propagated-inputs
-     `(("github.com/felixge/httpsnoop" ,go-github-com-felixge-httpsnoop)))
-    (arguments
-     '(#:tests? #f                      ; Tries to download from the internet
-       #:import-path "github.com/gorilla/handlers"))
-    (home-page "https://github.com/gorilla/handlers")
-    (synopsis "Middleware for Go HTTP services and web applications")
-    (description "A collection of useful middleware for Go HTTP services
-and web applications.")
-    (license license:bsd-3)))
-
 (define-public go-github-com-gorilla-securecookie
   (package
     (name "go-github-com-gorilla-securecookie")