summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-13 19:11:24 -0500
committerLeo Famulari <leo@famulari.name>2021-12-13 19:15:23 -0500
commit94836b215630ad0f4a7c06b8e4284d923ac1197f (patch)
tree5803cf834917345a67ff50c2f95a44e520c17a98 /gnu/packages/gtk.scm
parentbdcfe80b41e3d973591272036461c263d3713b22 (diff)
downloadguix-94836b215630ad0f4a7c06b8e4284d923ac1197f.tar.gz
gnu: python2-pygtk2: Temporarily revert to the old style of inputs.
This fixes the build of this package.

Reported in #guix by jpoiret, ss2, and tschilptschilp23.

* gnu/packages/gtk.scm (python2-pygtk)[propagated-inputs]: Restore the label
expected in the 'fix-codegen' build phase.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 53bfd1faa2..a7e5d10e10 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1941,9 +1941,9 @@ printing and other features typical of a source code editor.")
        ("libglade" ,libglade)
        ("glib"   ,glib)))
     (propagated-inputs
-     (list python2-pycairo ;loaded at runtime
-           python2-pygobject-2 ;referenced in pc file
-           gtk+-2))
+     `(("python-pycairo"   ,python2-pycairo)     ;loaded at runtime
+       ("python-pygobject" ,python2-pygobject-2) ;referenced in pc file
+       ("gtk+"             ,gtk+-2)))
     (arguments
      `(#:tests? #f
        #:phases (modify-phases %standard-phases