summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:17:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:43:23 +0200
commit24a2e19c432580a1a4900417ce81a4826e41e8f4 (patch)
tree3c9be10715cbf0b69b2918dce8911377abd214f2 /gnu/packages/video.scm
parent4e94cdb652ca30b74ad68153da976827c8ea16a2 (diff)
downloadguix-24a2e19c432580a1a4900417ce81a4826e41e8f4.tar.gz
gnu: python-waf: Use a proper directory structure.
Fixes <https://bugs.gnu.org/25634>.

* gnu/packages/python.scm (python-waf): Replace custom 'install phase to
install "waf" binary into the bin directory. Remove the 'wrap phase.
* gnu/packages/video.scm (mpv)[arguments]: Adjust the 'setup-waf phase
accordingly.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f4e461119b..8a5e730bd5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1180,7 +1180,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
          (add-before
           'configure 'setup-waf
           (lambda* (#:key inputs #:allow-other-keys)
-            (copy-file (assoc-ref inputs "waf") "waf")
+            (let ((waf (assoc-ref inputs "waf")))
+              (copy-file (string-append waf "/bin/waf") "waf"))
             (setenv "CC" "gcc")
             #t)))
        #:configure-flags (list "--enable-libmpv-shared"