summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:07 +0200
commit039ecfdc872810a591a6f4bb89190a015a4631a5 (patch)
tree33bfa9070ee62298ee21b23ac4e6b78d4f0c6565 /gnu/packages
parent5e6b27f66151ec6d4712969ef6e8b09a20ffdfad (diff)
downloadguix-039ecfdc872810a591a6f4bb89190a015a4631a5.tar.gz
gnu: Add texlive-showdim.
* gnu/packages/tex.scm (texlive-showdim): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c4b58263e4..9f7ac3ca2c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95527,6 +95527,26 @@ any.  The @code{\\showcs} variant helps with macros with exotic names.")
 is, and displaying width, height, and depth information of the character.")
     (license license:lppl1.3+)))
 
+(define-public texlive-showdim
+  (package
+    (name "texlive-showdim")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/showdim/" "tex/latex/showdim/")
+             (base32
+              "1hr2hfrvgqyfqaj9jgwiikcpf1pnslg8v0zw5qbj1ii6r7l8vrrd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/showdim")
+    (synopsis "Variants on printing dimensions")
+    (description
+     "This LaTeX package provides a number of commands for printing the value of
+a TeX dimension.  For example, @code{\\tenthpt@{\\baselineskip@}} yields the
+current value of @code{\\baselineskip} rounded to the nearest tenth of
+a point.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar