summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:49:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:59 +0200
commit50e433f08c49652fe9c236edca2bf7665e8e4531 (patch)
treef21544fa530453104a8828e9ba0e1122f4658e1d /gnu/packages
parent2ac3526bdf2dc43e9b35b404878350f82c823063 (diff)
downloadguix-50e433f08c49652fe9c236edca2bf7665e8e4531.tar.gz
gnu: Add texlive-fontwrap.
* gnu/packages/tex.scm (texlive-fontwrap): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 21805a5dfe..974434859b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5654,6 +5654,25 @@ hanging punctuation, and support for special Unicode characters.")
 evaluation, etc.).")
     (license license:lppl1.3+)))
 
+(define-public texlive-fontwrap
+  (package
+    (name "texlive-fontwrap")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/xelatex/fontwrap/"
+                   "tex/xelatex/fontwrap/")
+             (base32
+              "0nzphhwgm9387mn2rfhmsandyvcwv99lxm5978jg6pycs43dggs7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/fontwrap")
+    (synopsis "Bind fonts to specific Unicode blocks")
+    (description
+     "The package (which runs under XeLaTeX) lets you bind fonts to specific
+Unicode blocks, for automatic font tagging of multilingual text.")
+    (license license:gpl3+)))
+
 (define-public texlive-garrigues
   (package
     (name "texlive-garrigues")