summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:59 +0200
commit67ee23d68f8ad8c772752e9f636f2305669a4faa (patch)
tree101c3dc775d836fc9c4ed65391f56a006ecb6d42 /gnu/packages
parent85400ef86c0ccbfa8b6f21836d9b8d89c8573ce9 (diff)
downloadguix-67ee23d68f8ad8c772752e9f636f2305669a4faa.tar.gz
gnu: Add texlive-titleref.
* gnu/packages/tex.scm (texlive-titleref): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index baa328b97e..a5d2bb25cb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98280,6 +98280,27 @@ a LaTeX document.  The package currently only works with the document classes
 @code{article}, @code{report} and @code{book}.")
     (license license:public-domain)))
 
+(define-public texlive-titleref
+  (package
+    (name "texlive-titleref")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/titleref/" "tex/latex/titleref/")
+             (base32
+              "16s0kqln0mzs9mqnsw8rv5rpqizpd3r3lgmw3wl1yrrbq11n9grh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/titleref")
+    (synopsis "@code{\\titleref} command to cross-reference section titles")
+    (description
+     "This package defines a command @code{\\titleref} that allows you to
+cross-reference section (and chapter, etc) titles and captions just like
+@code{\\ref} and @code{\\pageref}.  The package does not interwork with
+@code{hyperref}; if you need @code{hypertext} capabilities, use @code{nameref}
+instead.")
+    (license license:public-domain)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar