summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 10:24:35 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 18:23:46 +0100
commit86c9c0c11819f1e5ec6f821265a0492ddeaf83ee (patch)
tree8462a42b10bc3c17a24b3306fd60319448d9e2b7 /gnu/packages
parent98516883927f39073360adbdc5ab25e16248e297 (diff)
downloadguix-86c9c0c11819f1e5ec6f821265a0492ddeaf83ee.tar.gz
gnu: webkitgtk: Update to 2.20.0.
* gnu/packages/webkit.scm (webkitgtk): Update to 2.20.0.
[arguments]: (Re-)disable WOFF2 web font support.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/webkit.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 340221640c..99852aa0f3 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -54,14 +55,14 @@
 (define-public webkitgtk
   (package
     (name "webkitgtk")
-    (version "2.18.6")
+    (version "2.20.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.webkitgtk.org/releases/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0g5cpdijjv5hlrbi4i4dh97yrh5apnyvm90wpr9f84hgyk12r4ck"))))
+                "0g0an3pc2yz13gzpaysfgch2yp510gw1qcpk0xr8m6mx43vl1xjp"))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f ; no tests
@@ -79,7 +80,12 @@
                           ;; included.  More investigation is needed.  For
                           ;; now, we explicitly disable it to prevent an error
                           ;; at configuration time.
-                          "-DUSE_GSTREAMER_GL=OFF")
+                          "-DUSE_GSTREAMER_GL=OFF"
+
+                          ;; XXX Disable WOFF2 ‘web fonts’.  These were never
+                          ;; supported in our previous builds.  Enabling them
+                          ;; requires building libwoff2 and possibly woff2dec.
+                          "-DUSE_WOFF2=OFF")
        #:phases
        (modify-phases %standard-phases
          (add-after