summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-19 00:47:10 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:28:37 +0200
commit986e9025a5232155e2b1deb2db15229c302d921a (patch)
tree4f0b77fb7bca98fc90b7892a5f502532349ba26c /gnu/packages
parent4ea6852c5ff1606cf6848f3ddbb669120b228c13 (diff)
downloadguix-986e9025a5232155e2b1deb2db15229c302d921a.tar.gz
gnu: guile-static: Remove obsolete workaround.
* gnu/packages/make-bootstrap.scm (make-guile-static)[arguments]: Don't
disable JIT on ARMv7.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index f176e56711..73e78879ea 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -702,12 +702,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
           ;; When `configure' checks for ltdl availability, it
           ;; doesn't try to link using libtool, and thus fails
           ;; because of a missing -ldl.  Work around that.
-
-          ;; XXX: On ARMv7, disable JIT: it causes crashes with 3.0.2,
-          ;; possibly related to <https://bugs.gnu.org/40737>.
-          (if (target-arm32?)
-              ''("LDFLAGS=-ldl" "--disable-jit")
-              ''("LDFLAGS=-ldl")))
+          ''("LDFLAGS=-ldl"))
          ((#:phases phases '%standard-phases)
           `(modify-phases ,phases