summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:31 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:05 +0000
commita4c40efa0558804b9d641c6624cfe06a668a6af6 (patch)
tree286b2f2cf0ca2976d1543dbf4eeff501258398cd /gnu/packages
parent40e07889d13ad447f8f79060a4b0c6d8febe3959 (diff)
downloadguix-a4c40efa0558804b9d641c6624cfe06a668a6af6.tar.gz
gnu: freedesktop: Unconditionally use alternatives to % variables.
* gnu/packages/freedesktop.scm
  (elogind)[arguments]<#:configure-flags>: Use #$output and this-package-input
  instead of %outputs and %build-inputs.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 550253bc34..9bcf2d8d3e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -583,20 +583,12 @@ the freedesktop.org XDG Base Directory specification.")
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
-       ;; TODO(core-updates): Use #$output unconditionally.
-       ,#~(let* ((out #$(if (%current-target-system)
-                            #~#$output
-                            #~(assoc-ref %outputs "out")))
+       ,#~(let* ((out #$output)
                  (sysconf (string-append out "/etc"))
                  (libexec (string-append out "/libexec/elogind"))
                  (dbuspolicy (string-append out "/etc/dbus-1/system.d"))
-                 ;; TODO(core-updates): use this-package-input unconditionally.
-                 (shadow #$(if (%current-target-system)
-                               (this-package-input "shadow")
-                               #~(assoc-ref %build-inputs "shadow")))
-                 (shepherd #$(if (%current-target-system)
-                                 (this-package-input "shepherd")
-                                 #~(assoc-ref %build-inputs "shepherd")))
+                 (shadow #$(this-package-input "shadow"))
+                 (shepherd #$(this-package-input "shepherd"))
                  (halt-path (string-append shepherd "/sbin/halt"))
                  (kexec-path "")           ;not available in Guix yet
                  (nologin-path (string-append shadow "/sbin/nologin"))