summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:37:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:47 +0200
commitba66383cd685b15a8fc8a29e446a4febe20f36b7 (patch)
treeae77eb1310641384ac12b7ff7483bbb6c01cd4cc /gnu/packages
parent3d6265154aae045dd25ca4650ab04348ad608c8a (diff)
downloadguix-ba66383cd685b15a8fc8a29e446a4febe20f36b7.tar.gz
gnu: Add texlive-pst-uml.
* gnu/packages/tex.scm (texlive-pst-uml): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8147cec1bc..213116925a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34286,6 +34286,28 @@ It is similar to @code{pst-tree}, though it uses a different placement
 algorithm.")
     (license license:lppl1.3+)))
 
+(define-public texlive-pst-uml
+  (package
+    (name "texlive-pst-uml")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-uml/"
+                   "source/generic/pst-uml/"
+                   "tex/latex/pst-uml/")
+             (base32
+              "0sgsyg9gk4wxgz7r44h6a7f5f7gl5b522f864n0kv35cgmwnzyr7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-multido))
+    (home-page "https://ctan.org/pkg/pst-uml")
+    (synopsis "UML diagrams with PSTricks")
+    (description
+     "This a PSTricks package that provides support for drawing moderately
+complex UML (Universal Modelling Language) diagrams.  (The PDF documentation
+is written in French.)")
+    (license license:lppl)))
+
 (define-public texlive-marginnote
   (package
     (name "texlive-marginnote")