summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-19 23:27:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-19 23:28:03 +0200
commitc5cf47ccffd9343c30a4a957aa8cb27e218acfe4 (patch)
treeb1533924d2717264f762afbaabc35071491bbde2 /gnu/packages
parent8c56ab99d93c2d37fcc08d3fcff44c64b12ed443 (diff)
downloadguix-c5cf47ccffd9343c30a4a957aa8cb27e218acfe4.tar.gz
gnu: Add python-lambda-4dn.
* gnu/packages/web.scm (python-lambda-4dn): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1b4eafeab8..e9c6f1443c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -98,6 +98,7 @@
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
   #:use-module (guix build-system scons)
   #:use-module (guix build-system trivial)
@@ -4807,6 +4808,31 @@ http://opensearch.a9.com} compatible search engines.")
 their web site.")
     (home-page "https://metacpan.org/release/WWW-RobotRules")))
 
+(define-public python-lambda-4dn
+  (package
+    (name "python-lambda-4dn")
+    (version "0.12.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "python-lambda-4dn" version))
+              (sha256
+               (base32
+                "1p5i8wsi8q5fpq63i7n7ri1w1lnh4gpn17f88vhkbh14aah5wxj1"))))
+    (properties '(("upstream-name" . "python-lambda-4dn")))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-boto3 python-botocore python-docutils
+           python-six))
+    (home-page "https://github.com/4dn-dcic/python-lambda")
+    (synopsis
+     "Toolkit for developing and deploying Python code in AWS Lambda")
+    (description
+     "This is a toolset for developing and deploying serverless Python code in
+AWS Lambda.  This is a fork of Nick Ficano's Python-lambda package.  It is
+frozen for the needs of projects at the 4D Nucleome Data Coordination and
+Integration Center (4DN-DCIC).")
+    (license (list license:isc license:expat))))
+
 (define-public python-feedparser
   (package
     (name "python-feedparser")