summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-13 20:47:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:19:21 +0000
commitd6cc85825feedba6a15717cc5e835b79aec5cb12 (patch)
tree11f55e201443f63d1f7ed25a5f9dfedfb1259eb6 /gnu/packages
parent643900518d07144d7c1466e221cc02cc95dcf9b7 (diff)
downloadguix-d6cc85825feedba6a15717cc5e835b79aec5cb12.tar.gz
gnu: go-github-com-schollz-progressbar-v3: Remove examples.
* gnu/packages/golang.scm (go-github-com-schollz-progressbar-v3): Remove
examples.
[arguments] <#:phases>: Add remove-examples phase.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: Ib1aa91160a8e94624d484654572da1b89305e076
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d95569cca1..ed34e16f27 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10243,6 +10243,10 @@ kubernetes-sigs/yaml is a permanent fork of
      (list #:import-path "github.com/schollz/progressbar/v3"
            #:phases
            #~(modify-phases %standard-phases
+               (add-after 'unpack 'remove-examples
+                 (lambda* (#:key import-path #:allow-other-keys)
+                   (delete-file-recursively
+                    (string-append "src/" import-path "/examples"))))
                (replace 'check
                  (lambda* (#:key tests? import-path #:allow-other-keys)
                    (when tests?