summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:46:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:31 +0200
commitdad815d74385711db9327c8d8618bb9d9c39fd5e (patch)
treea4d6975b6002c2dd39dd6fc2fda1ff33060f03a1 /gnu/packages
parentc058f86b1c2e44e0b8f54ac72f7c7b4335bade6d (diff)
downloadguix-dad815d74385711db9327c8d8618bb9d9c39fd5e.tar.gz
gnu: Add texlive-noto-emoji.
* gnu/packages/tex.scm (texlive-noto-emoji): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b3d05c0418..06b5d60fed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19800,6 +19800,25 @@ Both sorted and unsorted bibliography styles are supported.")
 generate bibliographies to be served on the web starting from BibTeX files.")
     (license license:public-domain)))
 
+(define-public texlive-noto-emoji
+  (package
+    (name "texlive-noto-emoji")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/noto-emoji/"
+                   "fonts/truetype/google/noto-emoji/")
+             (base32
+              "117mj4w0gvbndhm7mcxbxzxscd73np5s35467jr2sq2pwbv87i8r")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/noto-emoji")
+    (synopsis "Noto Emoji fonts")
+    (description
+     "Noto Color Emoji supports all emoji defined in the latest Unicode
+version.")
+    (license license:silofl1.1)))
+
 (define-public texlive-nuc
   (package
     (name "texlive-nuc")