summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:51:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:51:27 +0200
commit13cd7813f3a246a5ffb64c7a355c4eaf9feaadff (patch)
tree782d4b604f3019473221c81b013dd56ce8fbce41 /gnu
parent09442602397698c0dbe6a182cc8c8c7375a4a987 (diff)
downloadguix-13cd7813f3a246a5ffb64c7a355c4eaf9feaadff.tar.gz
gnu: Add texlive-jlreq.
* gnu/packages/tex.scm (texlive-jlreq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2cdb220748..85b02fb9a3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34314,6 +34314,31 @@ cite Japanese articles in the Institute of Electrical and Electronics
 Engineers (IEEE) format.")
     (license license:expat)))
 
+(define-public texlive-jlreq
+  (package
+    (name "texlive-jlreq")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/jlreq/"
+                   "fonts/tfm/public/jlreq/"
+                   "fonts/vf/public/jlreq/"
+                   "source/latex/jlreq/"
+                   "tex/latex/jlreq/"
+                   "tex/luatex/jlreq/")
+             (base32
+              "11jyj5mcyd9yxhb7mnm7naaaj26cgdk5iqkwna20109pcc2qy0wz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/jlreq")
+    (synopsis
+     "Japanese document class based on requirements for Japanese text layout")
+    (description
+     "This package provides a Japanese document class based on requirements
+for Japanese text layout.  The class file and the JFM (Japanese font metric)
+files for LuaTeX-ja, pLaTeX, or upLaTeX are provided.")
+    (license license:bsd-2)))
+
 (define-public texlive-libertine
   (package
     (name "texlive-libertine")