summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-06-23 13:48:47 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 09:45:16 +0200
commit155e3f2e87956a91412a79f1462863da4630e6c5 (patch)
treecffa62d36527eadf3934f9922fbff3b76f6d2175 /gnu
parent143ecd555a15164efc2bacda09598633e041b8a8 (diff)
downloadguix-155e3f2e87956a91412a79f1462863da4630e6c5.tar.gz
gnu: Add r-parallelmap.
* gnu/packages/cran.scm (r-parallelmap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b1eeb1ef53..22f2519a56 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2434,6 +2434,30 @@ programmed on.  A useful @code{OptPath} object (archive) to log function
 evaluations is also provided.")
     (license license:bsd-2)))
 
+(define-public r-parallelmap
+  (package
+    (name "r-parallelmap")
+    (version "1.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "parallelMap" version))
+              (sha256
+               (base32
+                "1qg7zpz5sd9jp8wzjqahkhipwj1jn192llwg06q4gv9mlcsac261"))))
+    (properties `((upstream-name . "parallelMap")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bbmisc r-checkmate))
+    (home-page "https://parallelmap.mlr-org.com")
+    (synopsis "Unified interface to parallelization backends")
+    (description
+     "This package provides a unified parallelization framework for multiple
+backends.  This package is designed for internal package and interactive
+usage.  The main operation is parallel mapping over lists.  It supports local,
+multicore, mpi and BatchJobs mode.  It allows tagging of the parallel
+operation with a level name that can be later selected by the user to switch
+on parallel execution for exactly this operation.")
+    (license license:bsd-2)))
+
 (define-public r-pheatmap
   (package
     (name "r-pheatmap")