summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-06 11:25:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:34 +0100
commit1fb5d95e75e1271e16bc51db21eb1205ebc4c777 (patch)
tree0aeb90f90ea8a5655ee34cb9777148f98f4cf60f /gnu
parent1d9169847886985f2b45fddc458d92244f311a68 (diff)
downloadguix-1fb5d95e75e1271e16bc51db21eb1205ebc4c777.tar.gz
gnu: python-doit: Update to 0.36.0.
* gnu/packages/python-xyz.scm (python-doit): Update to 0.36.0.
[build-system]: Use pyproject-build-system.
[arguments]: Disable test_execute test.
[propagated-inputs]: Remove python-pyinotify; add python-importlib-metadata.
[description]: Add missing spaces between two sentences.

Change-Id: I1d046201c9bef63477f8fb0a2f8494bffbbbc711
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b29dd2a386..22c76aa201 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33003,18 +33003,20 @@ of several plugins.")
 (define-public python-doit
   (package
     (name "python-doit")
-    (version "0.34.0")
+    (version "0.36.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "doit" version))
         (sha256
-          (base32 "0bf0m9n0hyjvjpv051zd26725j8jr23gyvc37v3kkadwbh8dxwcf"))))
-    (build-system python-build-system)
+          (base32 "1g1lwaxb9q3a6c24sr3gw5bspsk5frbrk2frb7z25jqljp67rl3i"))))
+    (build-system pyproject-build-system)
+    ;; This is not a serious test failure.  It's probably due to the load path
+    ;; at test time.
+    (arguments (list #:test-flags '(list "-k" "not test_execute")))
     (propagated-inputs
-      (list python-cloudpickle python-pyinotify))
-    (native-inputs
-      (list python-pytest))
+     (list python-cloudpickle python-importlib-metadata))
+    (native-inputs (list python-pytest))
     (home-page "https://pydoit.org")
     (synopsis "Automation tool to execute any kind of task in a build-tools
 fashion")
@@ -33023,7 +33025,7 @@ build-tools to execute any kind of task.
 
 A task describes some computation to be done (actions), and contains some
 extra meta-data.  The actions can be external programs or Python functions.  A
-single task may define more than one action.doit uses the task’s meta-data
+single task may define more than one action.  doit uses the task’s meta-data
 to:
 
 @itemize