summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-09-08 12:48:35 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-09 10:27:54 +0200
commit219e0a497e734ebd5705a30090a76d2894c4c31b (patch)
tree3f01eeda3e24f39db34c14974e68b54dcf61e157 /gnu
parent65d96ea4b83ed642cb7e3b2d6246ed154942e20d (diff)
downloadguix-219e0a497e734ebd5705a30090a76d2894c4c31b.tar.gz
gnu: taglib: Fix 'taglib-config --libs' -L flag.
* gnu/packages/mp3.scm (taglib): Add "" around the substitution of
ZLIB_LIBRARIES_FLAGS and add "/lib".

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mp3.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index a7574f0cf9..fdc8ba801f 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -182,9 +182,9 @@ a highly stable and efficient implementation.")
                        ;; flag for zlib.
                        (substitute* "CMakeLists.txt"
                          (("set\\(ZLIB_LIBRARIES_FLAGS -lz\\)")
-                          (string-append "set(ZLIB_LIBRARIES_FLAGS -L"
+                          (string-append "set(ZLIB_LIBRARIES_FLAGS \"-L"
                                          (assoc-ref inputs "zlib")
-                                         " -lz)")))
+                                         "/lib -lz\")")))
                        #t)))))
     (inputs `(("zlib" ,zlib)))
     (home-page "https://taglib.org")