summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:32 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:21 +0300
commit2ff90902c07ad377f94d94bd2b047e7170171a41 (patch)
tree68674d38e64eae2053df1f4dac0789f58af2b015 /gnu
parentb08be61a026fae900d37c158fd1b251bf21f5450 (diff)
downloadguix-2ff90902c07ad377f94d94bd2b047e7170171a41.tar.gz
gnu: Add python-rad.
* gnu/packages/astronomy.scm (python-rad): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 25b6d6a07e..93f19f9195 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3082,6 +3082,36 @@ the entire transformation pipeline from input coordinates (detector by
 default) to world coordinates.")
     (license license:bsd-3)))
 
+(define-public python-rad
+  (package
+    (name "python-rad")
+    (version "0.15.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "rad" version))
+              (sha256
+               (base32
+                "0j51pkywxdaqrfz162rdsywlvx1mbb2h0gi5framvhf25i1im7mb"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags #~(list "-k" "not remote_data")))
+    (native-inputs (list python-astropy
+                         python-pytest
+                         python-pytest-doctestplus
+                         python-pytest-openfiles
+                         python-semantic-version
+                         python-setuptools-scm))
+    (propagated-inputs (list python-asdf python-asdf-astropy))
+    (home-page "https://github.com/spacetelescope/rad")
+    (synopsis "Roman Attribute Dictionary")
+    (description
+     "@acronym{RAD, The Roman Attribute Dictionary} is package which defines
+schemas for the Nancy Grace Roman Space Telescope shared attributes for
+processing and archive.  These schemas are schemas for the ASDF file file
+format, which are used by ASDF to serialize and deserialize data for the Nancy
+Grace Roman Space Telescope.")
+    (license license:bsd-3)))
+
 (define-public python-astroalign
   (package
     (name "python-astroalign")