summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 19:08:11 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:04 +0200
commit932462536bfe9947eee205514ee52f1b05165f2b (patch)
tree8da31b84cc2d29be158dda3b769c2860e70d12cd /gnu
parent659692c0c31bd91abbfe778e798c481b24292900 (diff)
downloadguix-932462536bfe9947eee205514ee52f1b05165f2b.tar.gz
gnu: Add python-django-overextends.
* gnu/packages/django.scm (python-django-overextends, python2-django-overextends):
New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 260a689fca..129aa25806 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -437,3 +437,37 @@ entries, photos, book chapters, or anything else.")
 
 (define-public python2-django-contrib-comments
   (package-with-python2 python-django-contrib-comments))
+
+(define-public python-django-overextends
+  (package
+    (name "python-django-overextends")
+    (version "0.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "django-overextends" version))
+              (sha256
+               (base32
+                "0qc2pcf3i56pmfxh2jw7k3pgljd8xzficmkl2541n7bkcbngqfzm"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "./test_project/manage.py" "test")))))))
+    (propagated-inputs
+     `(("python-django" ,python-django)))
+    (native-inputs
+     `(("sphinx-me" ,python-sphinx-me)))
+    (home-page "https://github.com/stephenmcd/django-overextends")
+    (synopsis "Circular template inheritance")
+    (description
+      "A Django reusable app providing the overextends template tag, a drop-in
+replacement for Django's extends tag, which allows you to use circular template
+inheritance.  The primary use-case for overextends is to simultaneously
+override and extend templates from other reusable apps, in your own Django
+project.")
+    (license license:bsd-2)))
+
+(define-public python2-django-overextends
+  (package-with-python2 python-django-overextends))