summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 18:54:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-13 00:17:37 +0200
commitc8a7cc69c9e5beedf89c1b98a42f82fd8a647646 (patch)
tree2711a6f4c2bb8da00f96f0a6df29984dc2503289 /gnu
parente7c67f1b69c373d6504928d52382b483e555e7f2 (diff)
downloadguix-c8a7cc69c9e5beedf89c1b98a42f82fd8a647646.tar.gz
gnu: python-oauthlib: Update to 3.0.1.
* gnu/packages/python-web.scm (python-oauthlib): Update to 3.0.1.
[arguments]: Replace check phase with pytest invokation.
[native-inputs]: Remove PYTHON-NOSE.  Add PYTHON-PYTEST and PYTHON-PYTEST-COV.
[properties]: Remove.
(python2-oauthlib)[native-inputs]: Remove PYTHON2-UNITTEST2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e5993164cd..d25e10eadb 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1433,16 +1433,22 @@ with python-requests.")
 (define-public python-oauthlib
   (package
     (name "python-oauthlib")
-    (version "1.0.3")
+    (version "3.0.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "oauthlib" version))
               (sha256
                (base32
-                "1bfrj70vdjxjw74khbyh6f0dksv7p5rh2346jnlrffyacd3gwjzg"))))
+                "163jg4a8f7c5ki655grrr47kgljy12wri3qly7ijf64sk1fjrqqc"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "pytest" "-vv"))))))
     (native-inputs
-     `(("python-nose" ,python-nose)
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
        ("python-mock" ,python-mock)))
     (propagated-inputs
      `(("python-cryptography" ,python-cryptography)
@@ -1453,15 +1459,10 @@ with python-requests.")
     (description
      "Oauthlib is a generic, spec-compliant, thorough implementation of the
 OAuth request-signing logic.")
-    (license license:bsd-3)
-    (properties `((python2-variant . ,(delay python2-oauthlib))))))
+    (license license:bsd-3)))
 
 (define-public python2-oauthlib
-  (let ((base (package-with-python2 (strip-python2-variant python-oauthlib))))
-    (package
-      (inherit base)
-      (native-inputs `(("python2-unittest2" ,python2-unittest2)
-                       ,@(package-native-inputs base))))))
+  (package-with-python2 python-oauthlib))
 
 (define-public python-rauth
   (package