summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-28 10:44:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-28 16:05:56 +0200
commitcb6f44d4e4384f481db4de8fec3f76635f32ad79 (patch)
treea1bc5aaec7e7f7e850ac270be15491b33952aa67 /gnu
parent1ec17821069601cbc45b31b4d80973c0a8947f35 (diff)
downloadguix-cb6f44d4e4384f481db4de8fec3f76635f32ad79.tar.gz
gnu: atlas: Always return #T from build phases.
* gnu/packages/maths.scm (atlas)[arguments]: Always return #T from build
phases; use INVOKE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e4e9c52598..6aa402b823 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3300,7 +3300,6 @@ packages.")
        #:substitutable? #f
 
        #:modules ((srfi srfi-26)
-                  (srfi srfi-1)
                   (guix build gnu-build-system)
                   (guix build utils))
        #:configure-flags
@@ -3333,11 +3332,11 @@ packages.")
              (let ((doc (string-append (assoc-ref outputs "doc")
                                        "/share/doc/atlas")))
                (mkdir-p doc)
-               (fold (lambda (file previous)
-                       (and previous (zero? (system* "cp" file doc))))
-                     #t (find-files "../ATLAS/doc" ".*")))))
+               (for-each (cut install-file <> doc)
+                         (find-files "../ATLAS/doc" ".*"))
+               #t)))
          (add-after 'check 'check-pt
-           (lambda _ (zero? (system* "make" "ptcheck"))))
+           (lambda _ (invoke "make" "ptcheck")))
          ;; Fix files required to run configure.
          (add-before 'configure 'fix-/bin/sh
            (lambda _
@@ -3372,9 +3371,9 @@ packages.")
                (chdir "../build")
                (format #t "build directory: ~s~%" (getcwd))
                (format #t "configure flags: ~s~%" flags)
-               (zero? (apply system* bash
-                             (string-append srcdir "/configure")
-                             flags))))))))
+               (apply invoke bash
+                      (string-append srcdir "/configure")
+                      flags)))))))
     (synopsis "Automatically Tuned Linear Algebra Software")
     (description
      "ATLAS is an automatically tuned linear algebra software library