summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 14:50:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:12 +0300
commitcc6b84347b9c5e99a3c5722ee46f0ca86a99b31c (patch)
tree07991257471f5bcb0bdc5b2c7eb8482807637053 /gnu
parent3daa7f6277f78b953a4bcc667fbf92e5482b3551 (diff)
downloadguix-cc6b84347b9c5e99a3c5722ee46f0ca86a99b31c.tar.gz
gnu: Add rust-resize-0.4.
* gnu/packages/crates-graphics.scm (rust-resize-0.4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 04dee1ec09..5d5319a387 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2262,6 +2262,25 @@ AVIF format (powers the `cavif` tool).")
     (arguments
      `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))))
 
+(define-public rust-resize-0.4
+  (package
+    (name "rust-resize")
+    (version "0.4.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "resize" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0bamrw2m37l8q46mcy6snp6106d93dq7x67hbbj32w88pjdhxn84"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs (("rust-png" ,rust-png-0.16))))
+    (home-page "https://github.com/PistonDevelopers/resize")
+    (synopsis "Image resampling library in pure Rust")
+    (description "This package provides an image resampling library in pure Rust.")
+    (license license:expat)))
+
 (define-public rust-rgb-0.8
   (package
     (name "rust-rgb")