summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 21:19:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:27 +0200
commite4696fdfc20f2594ab40892bdaadf0a1b8a94779 (patch)
tree5d9babd611eccd7e887da26173c01353958dfa0f /gnu
parent76272cc6619a8d042da16dfb13273ee000518d3d (diff)
downloadguix-e4696fdfc20f2594ab40892bdaadf0a1b8a94779.tar.gz
gnu: Add texlive-biblatex-oxref.
* gnu/packages/tex.scm (texlive-biblatex-oxref): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5051706bce..7094015992 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4258,6 +4258,45 @@ you cite two entries which share the same booktitle but not the same title,
 the @samp{op.@: cit.}@: mechanism does not work.  This package fixes this.")
     (license license:lppl1.3+)))
 
+(define-public texlive-biblatex-oxref
+  (package
+    (name "texlive-biblatex-oxref")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/biblatex-oxref/"
+                   "source/latex/biblatex-oxref/"
+                   "tex/latex/biblatex-oxref/")
+             (base32
+              "0jzmb28h0s2nji23mkj5ich7z5kaifv3snj20rm0dpjk20a087h3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/biblatex-oxref")
+    (synopsis "BibLaTeX styles inspired by the @emph{Oxford Guide to Style}")
+    (description
+     "This bundle provides four BibLaTeX styles that implement (many of) the
+stipulations and examples provided by the 2014 @emph{New Hart's Rules} and the
+2002 @emph{Oxford Guide to Style}:
+@itemize
+
+@item @code{oxnotes} is a style similar to the standard @code{verbose},
+intended for use with footnotes;
+
+@item @code{oxnum} is a style similar to the standard @code{numeric}, intended
+for use with numeric in-text citations;
+
+@item @code{oxalph} is a style similar to the standard @code{alphabetic},
+intended for use with alphabetic in-text citations;
+
+@item @code{oxyear} is a style similar to the standard @code{author-year},
+intended for use with parenthetical in-text citations.
+
+@end itemize
+
+The bundle provides support for a wide variety of content types, including
+manuscripts, audiovisual resources, social media and legal references.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibleref
   (package
     (name "texlive-bibleref")