about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2023-03-22 11:13:20 +0000
committerFrank Busse <f.busse@imperial.ac.uk>2023-03-22 20:52:25 +0000
commit5607a7f1910e579acc0b93b1ae2caba88e7d5fd7 (patch)
tree586a8d40348940aed51a6c406dd35984da159ecb /CMakeLists.txt
parent318c63700372099a60566a3af4e0ec02dfd22073 (diff)
downloadklee-5607a7f1910e579acc0b93b1ae2caba88e7d5fd7.tar.gz
Change `llvm_map_components_to_libnames` to `llvm_config` CMake function
With recent LLVM versions, this should allow to link against dynamic LLVM
libraries.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd8e9d75..024d8a50 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -185,6 +185,11 @@ if (NOT EXISTS "${LLVM_AS}")
   message(FATAL_ERROR "Failed to find llvm-as at \"${LLVM_AS}\"")
 endif()
 
+# Check for dynamic linking
+if (LLVM_LINK_LLVM_DYLIB)
+  set(USE_LLVM_SHARED USE_SHARED)
+endif()
+
 ################################################################################
 # C++ version
 ################################################################################