about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2020-04-06 14:22:30 +0100
committerCristian Cadar <c.cadar@imperial.ac.uk>2020-11-04 15:14:47 +0000
commit5b8e54a95bc2e1f373710aa62f5e6b70768555e7 (patch)
tree4b9617663fd99bd58be67c16295d36fb196a57a8 /CMakeLists.txt
parenta00424e64d56ff881a72bfd99ea0dbcbe6898b49 (diff)
downloadklee-5b8e54a95bc2e1f373710aa62f5e6b70768555e7.tar.gz
[cmake] Always create KLEE runtime directory even if POSIX is not built
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8841e546..12ec29c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -491,6 +491,8 @@ set(KLEE_INSTALL_RUNTIME_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/klee/runtime")
 # Location where KLEE will look for the built runtimes by default.
 set(KLEE_RUNTIME_DIRECTORY "${CMAKE_BINARY_DIR}/${KLEE_RUNTIME_BUILD_TYPE}/lib")
 
+file(MAKE_DIRECTORY ${KLEE_RUNTIME_DIRECTORY})
+
 ################################################################################
 # KLEE POSIX Runtime Support
 ################################################################################
@@ -532,7 +534,6 @@ if (ENABLE_KLEE_UCLIBC)
 
   # Make a symlink to KLEE_UCLIBC_C_BCA so KLEE can find it where it
   # is expected.
-  file(MAKE_DIRECTORY "${KLEE_RUNTIME_DIRECTORY}")
   execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink
     "${KLEE_UCLIBC_C_BCA}"
     "${KLEE_RUNTIME_DIRECTORY}/${KLEE_UCLIBC_BCA_NAME}"