about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Büning <julian.buening@rwth-aachen.de>2018-11-04 11:34:10 +0100
committerCristian Cadar <c.cadar@imperial.ac.uk>2019-03-05 15:15:39 +0000
commit7e33d5cb292c88ae10f4a0ffa86c498168fbe16a (patch)
tree769f3ff2ba656810198fe7a4416058c68f6096f0 /CMakeLists.txt
parentd5de3df2c7e481426c39220072b42dfd307a3526 (diff)
downloadklee-7e33d5cb292c88ae10f4a0ffa86c498168fbe16a.tar.gz
workaround for LLVM PR39177
provides a workaround for LLVM bug PR39177, which affects LLVM
versions 3.9 - 7.0.0: https://bugs.llvm.org/show_bug.cgi?id=39177

This commit is intended to be reverted once support for LLVM
versions <= 7 is dropped from KLEE.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a41d0f3..164ce1a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -496,6 +496,11 @@ else()
 endif()
 
 ################################################################################
+# Workarounds
+################################################################################
+include(${CMAKE_SOURCE_DIR}/cmake/workaround_llvm_pr39177.cmake)
+
+################################################################################
 # Global clean target
 ################################################################################
 # CMake already uses the "clean" target name but it doesn't clean everything