about summary refs log tree commit diff homepage
path: root/shell.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-16 20:52:49 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-16 20:52:49 +0900
commit21f317aab2368ec6ef341dc23b4257ffa24946af (patch)
treef525eb1f04c031dc5b3d3817e7588f860d0cad3f /shell.nix
parente24d423e566d3cc688acd359991359d59990e3cb (diff)
downloadpx-21f317aab2368ec6ef341dc23b4257ffa24946af.tar.gz
Use symlink instead of meta refresh redirect
I couldn't figure out a way to disable caching for the latter.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..667fe41
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,9 @@
+with import <nixpkgs> {};
+mkShell {
+  packages = [ busybox epeg inotify-tools libxslt webfs ];
+  shellHook = ''
+    make -j $(nproc) live
+    webfsd -p 28792 -f index.xml
+    trap "kill $(pgrep -f 'webfsd -p 28792')" EXIT INT TERM
+  '';
+}