about summary refs log tree commit diff homepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..667fe41
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,9 @@
+with import <nixpkgs> {};
+mkShell {
+  packages = [ busybox epeg inotify-tools libxslt webfs ];
+  shellHook = ''
+    make -j $(nproc) live
+    webfsd -p 28792 -f index.xml
+    trap "kill $(pgrep -f 'webfsd -p 28792')" EXIT INT TERM
+  '';
+}