about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorNgô Ngọc Đức Huy <huyngo@disroot.org>2024-02-05 12:53:07 +0700
committerNgô Ngọc Đức Huy <huyngo@disroot.org>2024-02-26 16:33:20 +0700
commit21787993b7fa0ce24553839d5f19db1d14591d93 (patch)
treebb900a77531a093eaacb17b0c935cc279775da2d /shell.nix
parent62257f0b30bd58090429a7925adddb4a140995bd (diff)
downloadblog-21787993b7fa0ce24553839d5f19db1d14591d93.tar.gz
Add shell.nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..f2dff6d
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+# SPDX-FileCopyrightText: 2024 Ngô Ngọc Đức Huy <huyngo@disroot.org>
+#
+# SPDX-License-Identifier: CC-BY-SA-4.0
+
+{pkgs ? import <nixpkgs> {}
+}:
+pkgs.mkShell {
+  name="build-env";
+  buildInputs = with pkgs; [
+    hugo rsync mdbook
+  ]);
+}
+