about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..f2dff6d
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+# SPDX-FileCopyrightText: 2024 Ngô Ngọc Đức Huy <huyngo@disroot.org>
+#
+# SPDX-License-Identifier: CC-BY-SA-4.0
+
+{pkgs ? import <nixpkgs> {}
+}:
+pkgs.mkShell {
+  name="build-env";
+  buildInputs = with pkgs; [
+    hugo rsync mdbook
+  ]);
+}
+